Degraded Access to TSP Admin Console – maintenance overran by 34 min
Resolved
Jul 09 at 02:05pm UTC
Start time: 2025-07-09 13:31 UTC
End time: 2025-07-09 14:05 UTC
Duration: 34 minutes
We rolled out a scheduled update introducing the new granular access-role system.
During the migration, one of the database patch steps took longer than anticipated, holding an exclusive lock on the TSP Admin authorization.
Impact
* TSP Admin users experienced “403 / insufficient permissions” errors, login errors, or incomplete UI pages.
* No data loss; fleet app, driver apps, and API traffic continued normally.
We’re closely monitoring and apologize for the unexpected disruption.
Affected services
Created
Jul 09 at 01:31pm UTC
We rolled out a scheduled update introducing the new granular access-role system.
During the migration, one of the database patch steps took longer than anticipated, holding an exclusive lock on the TSP Admin authorization.
Affected services