Back to overview
Degraded

Degraded Performance Of Telemetry Engine

Aug 13 at 11:30am UTC
Affected services
Telemetry Engine

Resolved
Aug 14 at 10:30am UTC

As part of the release on August 13, 2025, we deployed updates to driver data integration. This caused some algorithms to recalculate previously received device data for past periods, resulting in significant delays in alert triggers and notifications.

Impact
The issue began at 12:30 PM UTC on August 13, 2025, and was fully resolved by 11:30 AM UTC on August 14, 2025. Users experienced delayed alerts and notifications during this time.

Resolution
We have resolved the problem and implemented additional safeguards to prevent similar incidents in the future.

We sincerely apologize to everyone affected.

Created
Aug 13 at 11:30am UTC

As part of the release, we performed updates related to driver data integration. As a result, some algorithms recalculated data previously received from devices for past periods. This led to significant delays in alert triggers and receiving notifications.