Back to overview
Downtime

Application availability impacted

Oct 09 at 02:51pm UTC
Affected services
Fleet WEB App Uptime
TSP Admin Uptime

Resolved
Oct 09 at 03:33pm UTC

Summary:

During our routine weekly release, we encountered a third-party outage on GitHub that affected critical endpoints and webhooks: https://www.githubstatus.com/incidents/k7bhmjkblcwp (Github is the most popular code repository and used by millions of companies). As a result, our deployment process was blocked, and only a partial version of the application got released. Because webhooks were nonfunctional, our CI/CD pipeline could not receive updates or trigger jobs, leading to downtime. To mitigate risk and preserve stability, we gracefully rolled back to the prior stable version, paused further releases, and waited for GitHub to restore service.

Root Cause:
The root cause was an external service outage on GitHub affecting their webhook / API infrastructure. This prevented our CI/CD processes from completing and deploying fully.

Impact:

  • Deployed services were only partially updated; some modules remained in an inconsistent state.
  • New builds and updates could not be triggered due to webhook failures in GitHub.
  • Users experienced unavailable functionality during the incident window.
  • Release rollout was postponed until GitHub’s systems became healthy again.

Remediation & Resolution:

  • We executed an emergency rollback to the last known good release.
  • Deployment was halted while monitoring GitHub’s status updates.
  • After GitHub’s incident resolved, we validated system stability and resumed controlled deployment
  • We ran a complete system testing verified end-to-end functionality after releasing new updates properly.

We apologize for any disruption this caused and thank you for your patience. If you have questions or need more details please reach out to support@telematicsinsights.ai

Created
Oct 09 at 02:51pm UTC

During our routine weekly release, we encountered a third-party outage on GitHub that affected critical endpoints and webhooks: https://www.githubstatus.com/incidents/k7bhmjkblcwp