Database Lock & Service Interruption
Resolved
Feb 25, 2026 at 01:26pm UTC
An administrative cleanup command held an "exclusive lock" on key resources, preventing normal application traffic from reading (or writing data in a few cases). This caused a "convoy effect" where incoming API requests queued up behind the lock, resulting in temporary service latency and unavailability.
🛠Resolution
The issue was resolved by rebooting the database instance to forcibly release the lock. This immediately cleared the pending command and allowed piled-up user requests to process normally. Service has fully recovered and processed queued tasks.
Affected services
Created
Feb 25, 2026 at 01:08pm UTC
During scheduled maintenance, the primary database experienced a critical Locking Incident.
Affected services